Cover

Documentation

QuaRef

Quasicrystal Reflection Generator

Version 1.2

© JCrystalSoft, 2011


Introduction

QuaRef is a stand-alone software for Windows. It creates lists of reflections for dihedral (octagonal, decagonal, dodecagonal) and icosahedral quasicrystals. It displays the 0th. layer as a static image and the the whole set of reflections in an interactive 3D viewer. The reflections can be rotated by dragging the mouse over the display area. For the simulation the user can choose between lattice matrices as used by Dr. Akiji Yamamoto or Prof. Walter Steurer. QuaRef observes the extinction rules for the chosen space groups. The encoded extinction rules are based on the paper by Rabson, Mermin, Rokshar, Wright, 1991. QuaRef is the successor to the DOS program QREFGEN.

References:

  • A.Yamamoto: Acta Cryst., A52, (1996), 509-560
  • W. Steurer: Zeitschrift f.Krist., 190, (1990), 179-234
  • Rabson, Mermin, Rokshar, Wright: Rev.Mod.Phys.,Vol.63, No.3, July 1991

Links to quasicrystal websites:

  • Steffen Weber's quasicrystal page

Disclaimer

The software QuaRef is provided on an "as is" basis without any warranty either expressed or implied as to its performance, quality, or fitness for any particular purpose. The entire risk is with the user. JCrystalSoft's and the author's liability for any damage arising out of the use of this software shall be limited to the price for this product. In no event shall JCrystalSoft be liable for indirect, special or consequential damages resulting from the use of the QuaRef software. This software product is copyrighted and all rights are reserved by JCrystalSoft and the program's author Dr. Steffen Weber. QuaRef may be freely copied and distributed. It is not permitted to sell this product. JCrystalSoft reserves the right to make changes or improvements in this software at any time and without notice.

Dr. Steffen Weber
author of QuaRef


Features

Main features

  • Calculation of reflection lists for dihedral and icosahedral quasicrystals
  • Yamamoto & Steurer matrices
  • QuaRef obeys extinction rules for chosen space group
  • 2D and 3D display of the reciprocal lattice points
  • Graphics: display of indices; different color codes
  • Direct printing of graphics
  • Export of graphics as Bitmap BMP
  • Export of graphics as Windows Metafile WMF (to clipboard)
  • Copy Tab separated lists to clipboard for use with MS-Excel etc.
  • Save reflection lists as ASCII files
  • Tiling Generator with Fourier Transform

What's new in version1.2

  • Applied more suitable start-up orientation for icosahedral system
  • Added dZ(3D) layer thickness slider
  • Added custom rotation buttons (use left/right mouse-click)
  • Added conversion of European decimal comma to decimal point


User Interface

QuaRef has an easy to use graphical user interface (GUI), which presents all control elements and data displays in one page. The control panel on the right side allows the selection of space groups matrix type, lattice constants, X-ray wavelength, index loop limits etc.

The main window space is reserved for presenting the data as a table with the calculated reflection list and two windows for 2D/3D graphics. The 3D graphics window is an interactive reciprocal space viewer. The set of reflections can be rotated by dragging it with the mouse.

In order to see the graphics better the 2D and 3D window can be switched to a large window mode


Controls

For creating a reflection list the user is to set the loop boundaries for the index loops. If for example the values 4 4 4 4 2 are chosen the loop will be executed for h1 = -4 to 4, h2 = -4 to 4, h3 = -4 to 4, h4 = -4 to 4, h5 = -2 to 2.

1. menus and display controls

  1. clear all
  2. save graphics as BMP or list as ASCII file
  3. copy graphics as WMF or list as TAB-delimited block
  4. print graphics or list
  5. toggle black/white background color
  6. start calculation
  7. zoom for 2D display (0.th layer)
  8. reset zoom for 2D display
  9. big window for 2D graphics
  10. zoom for 3D display (full set)
  11. reset zoom for 3D display
  12. big window for 3D graphics
  13. slider for spot radius factor

2. simulation setup

  1. select system and space group
  2. select lattice matrix type
  3. set lattice constants [A]
  4. set loop bounds for the generation of reflection indices
  5. set X-ray wavelength [A]
  6. set Bragg angle range and the maximum length in internal space (strong reflections have small qi values)
  7. search string for searching the list
  8. find / find next

3. status bar

The number of loops is usually higher the the number of generated reflections, because many reflections are being eliminated due to the settings for the theta range, qimax and extinction rules.


Extinction rules

QuaRef tries to obey the extinction rules for the chosen space group. The encoded extinction rules are based on geometric relationships of the projected wave vectors (reciprocal space vectors h1-h5 or h1-h6). Important directions are the so-called along-directions (parallel to the projection of the 10000, 01000, 00100 and 00010 vectors) and the so-called between-directions, which as the name suggests are parallel to directions that bisect two successive along-directions.

Fig.1 along directions (solid) and between directions (dashed)

Symbols used for encoding extinction rules for dihedral quasicrystals:

Z - zeroth layer | o - odd parity wave vectors
A - all layers | e - even parity wave vectors
E - even layers | a - along direction
O - odd layers | b - between direction

The code Oea for example would have to be read as: extinct are all reflections on Odd layers with even parity, whose projected wave vector lies parallel to an along direction

Implemented space group selection:

octagonal
1 P-8
2 I-8
3 P-8m2
4 P-8b2 (Aoa)
5 P-8c2 (Oa)
6 P-8n2 (Eoa Oea)
7 P-82m
8 P-82.1m (Zoa)
9 P-82c (Ob)
10 P-82.1c (Ob Zoa)
11 I-8m2
12 I-82m
13 I-82c (Ob)
14 P8
15 I8
16 P8mm
17 P8bm (Aoa)
18 P8cc (Oab)
19 P8nc (Oea Ob Eoa)
20 P8.4mc (Ob)
21 P8.4bc (Ob Aoa)
22 P8.4cm (Oa)
23 P8.4nm (Oea Eoa)
24 I8mm
25 I8mc (Ob)
26 P822
27 P82.12 (Zoa)
28 I822
29 P8/m
30 P8/n (Zo)
31 I8/m
32 P8/mmm
33 P8/mbm (Aoa)
34 P8/mcc (Oab)
35 P8/mnc (Oea Ob Eoa)
36 P8/nmm (Zo)
37 P8/nbm (Aoa Zo)
38 P8/ncc (Oab Zo)
39 P8/nnc (Oea Eoa Ob Zo)
40 P8.4/mmc (Ob)
41 P8.4/mbc (Ob Aoa)
42 P8.4/mcm (Oa)
43 P8.4/mnm (Oea Eoa)
44 P8.4/nmc (Ob Zo)
45 P8.4/nbc (Ob Aoa Zo)
46 P8.4/ncm (Oa Zo)
47 P8.4/nnm (Oea Eoa Zo)
48 I8/mmm
49 I8/mmc (Ob)

decagonal
50 P-10m2
51 P-10c2 (Oa)
52 P-102m
53 P-102c (Ob)
54 P10
55 P10mm
56 P10cc (Oab)
57 P10.5mc (Ob)
58 P10.5cm (Oa)
59 P1022
60 P10/m
61 P10/mmm
62 P10/mcc (Oab)
63 P10.5/mmc (Ob)
64 P10.5/mcm (Oa)

dodecagonal
65 P-122m
66 P12
67 P12mm
68 P12.6cm (Oa)
69 P12cc (Oab)
70 P1222
71 P12/m
72 P12/mmm
73 P12.6/mcm (Oa)
74 P12/mcc (Oab)

icosahedral

75 P235
76 P235.1 ( h1=5n for h1 h2 h2 h2 h2 h2)
77 I235
78 I235.1 (h1+5h2=10n for h1 h2 h2 h2 h2 h2)
79 F235
80 F235.1 (h1+5h2=10n for h1 h2 h2 h2 h2 h2)
81 Pm-3-5
82 Pn-3-5 (h5-h6=2n for h1 h2 -h1 -h2 h5 h6)
83 Im-3-5
84 Fm-3-5
85 Fn-3-5 (h5-h6=4n for h1 h2 -h1 -h2 h5 h6)

If you think you have found a mistake in the extinction rules contact me at steffenweber@home.com


Contacts

Author:

Steffen Weber, Ph.D.
Livermore, CA 94550, USA

Email:

Web:

jcrystalsoft@gmail.com