Cover

Dokumentation

JCrystal

Java Kristall Morphologie Editor/Betrachter

Version 1.05

© JCrystalSoft, 2000-2006


Einführung

JCrystal wurde ursprünglich auf die Bitte von Monte Nichols (Aleph Enterprises) geschrieben. Eine erste Version war seit 1999 erhältlich. Dave Barthelmy hat jene Version und dessen JCrystalApplet ausgiebig für seine Internet Mineraliendatenbank genutzt ( www.webmineral.com ). Das hat mich dann dazu motiviert, neuere Versionen zu schreiben, welche jetzt zum Herunterladen erhältlich sind.

JCrystal zeichnet Kristallformen für normale Kristalle und ikosaedrische Quasikrystalle. Es ist möglich, Webseiten in der HTML Sprache zu exportieren, welche das einbegriffene JCrystalApplet benutzen, so daß die erzeugten Kristallformen in einem Java-fähigen Webbrowser wie Microsoft Internet Explorer (MSIE) oder Netscape (NS) betrachtbar sind. Dies ist vielleicht die attraktivste Funktion von JCrystal. Das Hauptprogramm JCrystal selbst hat viel mehr Darstellungsmöglichkeiten als das Applet. Es kann aber somit auch als Benutzeroberfläche zur Erzeugung interaktiver Webseiten genutzt werden. Beachten Sie bitte, daß das standard Applet aus Kompatibilitätsgründen in einem früheren Java Dialekt geschrieben wurde, und somit nicht alle Darstellungsmöglichkeiten des Hauptprogrammes bietet aber dafür Webbrowserneutral ist. Eine neuere Version des JCrystalApplets ist im Verzeichnis "JCrystal\lib\SUN-JVM Applet" enthalten. Dieses wurde speziell für das Sun Microsystems Java Plug-in geschrieben und bietet auch Linienglättung (Antialiasing) und Flächentransparenz zur Darstellung an.

JCrystal kann PostScript Dateien für die Kristallformen und die Stereographischen Projektionen erzeugen. Um diese PostScript Dateien zu betrachten oder zu drucken sollte man die kostenlosen Programme GhostView mit GhostScript installieren. GhostView ist die Benutzeroberfläche für GhostScript, welches ein PostScript Interpreter ist.

Falls Sie Probleme oder Fehler bei der Nutzung von JCrystal finden, benutzen Sie bitte den Menüeintrag [Help][submit bug report] um uns darüber zu informieren (Internetverbindung notwendig).

Beispieldateien

Die meisten Beispieldateien im Verzeichnis "hkl\" und alle Schablonen (unvollendete Dateien, welche weiterberabeitet werden müssen) im Verzeichnis "hkl\Dave_Barthelmy" sind durch Dave Barthelmy bereit gestellt worden. Wenn Sie den Menüeintrag [Options][create templates] wählen, werden etwa 4000 Schablonen mit Mineraliendaten im Verzeichnis "hkl\templates" erzeugt. Diese Dateien sind keine echte Kristallformen, sondern enthalten den Mineralnamen, die Gitterkonstanten, den Punktgruppencode und eine minimale hkl-Liste, welche vom Benutzer modifiziert werden muss, um die korrekten Kristallformen zu erhalten. Die Beispieldateien im Verzeichnis "hkl\Udo_Behner" wurden durch Udo Behner bereit gestellt. Einige Dateibeispiele für das Importieren von Dateien der Programme SHAPE6 und FACES3.5 sind auch enthalten.

Disclaimer

The software JCrystal is sold on an "as is" basis without any warranty either expressed or implied as to its performance, quality, or fitness for any particular purpose. The entire risk is with the buyer. JCrystalSoft's liability for any damage arising out of the use of this software shall be limited to the price for this product. In no event shall JCrystalSoft be liable for indirect, special or consequential damages resulting from the use of the JCrystal software. JCrystalSoft will replace any CD which is found to be defective. This software product is copyrighted and all rights are reserved by JCrystalSoft and the program's author Dr. Steffen Weber. The software is licensed by JCrystalSoft to the original purchaser. Copying and duplicating (except for purposes of backup), selling, or otherwise distributing this product is not allowed.

JCrystalSoft reserves the right to make changes or improvements in this software at any time and without notice.

Dr. Steffen Weber
Autor von JCrystal


Funktionen

Programmfunktionen

Hauptfunktionen

  • Berechnung von Kristallformen
  • Ikosaedrische Quasikristalle
  • Exportieren von Webseiten mit einem interaktiven Java Applet
  • Einfacher hkl Flächen Editor
  • Zwei Werkzeuge zur Formenauswahl
  • Automatische Distanzmodifizierung für Flächen die außerhalb liegen
  • Photoreferenz und Beschreibungsoption
  • Synchronisierter Wulff Netz Monitor
  • Menü mit zuletzt geladenen Dateien [History]
  • Internet Refernzen (Links)
  • Transparente Kristallflächendarstellung
  • Drahtmodell, schattiertes Modell und Rot/Blau Stereo Darstellung (Anaglyph)
  • Ausgabe von GIF, JPG, PostScript, VRML, HTML, POVray Dateien

Andere Funktionen

  • Elementarzellenbetrachter
  • Stereographische Projectionen
  • Laue Simulationen
  • Periodensystem der Elemente
  • Drucken einer Auswahl von Papierbögen

Importieren von Dateien

  • Importieren von Dateien des Programmes FACES 3.5 (*.fac)
  • Importieren von Dateien des Programmes SHAPE 6 "face details files" (*.shd)

Shape's "details files" *.SHD müssen für Einzelkristalle sein, nicht für Zwillinge!
FACES 3.5 Dateien enthalten keine geeigneten Distanzwerte für die Flächen! JCrystal versucht, die hkl-Liste von den gegebenen Formen zu erzeugen, aber die Distanzen müssen manuell angepasst werden, um die gleiche Kristallform wie im Programm FACES 3.5 zu erzeugen.


Was ist neu ?

Version 1.05 (11/04/2006)

  • HTML Hilfe in diese CHM Hilfsdatei umgewandelt
  • Neue Version des JCrystalApplet
  • Optionales Applet für SUN-JVM mit Transparenz hinzugefügt

Version 1.04 (03/28/2005)

  • Modifiziertes Laue Simulationsmodul
  • Wechsel vom Verkauf auf CD zur herunterladbaren Installation

Version 1.03 (12/17/2003)

  • Modifiziertes Laue Simulationsmodul
  • Neue Beispieldateien von Dave Barthelmy ( www.webmineral.com )
  • Automatischer Internetupdate entfernt

Version 1.02 (01/20/2001)

  • Benutzung der DEL-Taste zum Entfernen der angehakten Flächen !
  • Benutzung der ENTER-Taste zum Wählen aller Flächen der gleichen Farbe !
  • Nicht automatisch speichern bei Neuberechnung
  • LEERZEICHEN startet Animation wie bei dem Applet
  • Menüeintrag [File][reload]
  • Eingabedateien können Formen angeben anstatt aller Einzelflächen
  • Exportieren von POVRAY Dateien

Version 1.01 (01/10/2001)

  • Drucken einer Auswahl von Papiermodellen
  • Automatisches Herunterladen von Updates
  • Fortgeschrittene Parameter einstellbar gemacht
  • Kontextmenü für das JCrystalApplet
  • Direkter Zugriff zu Internet Mineraldatenbanken
  • Neue Beispieldateien

Version 1.00 (12/01/2000)

  • Offizielle Herausgabe von JCrystal


Schnelleinstieg

Während der Installation wurde eine "JCrystal"-Ikone auf Ihrem Desktop erzeugt. Ein Doppel-klick darauf wird JCrystal starten.

Wenn Sie JCrystal zum erstenmal laufen lassen, werden Sie nach dem Registrierungspasswort gefragt, welches Ihnen per Email von JCrystalSoft geschickt wurde. Falls Sie kein solches Registrierungspasswort innerhalb von 24 Stunden erhalten haben emialen Sie bitte an jcrystalsoft@gmail.com . Es könnte sein, daß Sie eine ungültige Emailadresse angeben haben oder daß Ihr Emailserver die Email von JCrystalSoft abgeblockt hat.

1.

Beim Passwort bitte die Groß/Kleinschreibung beachten! Am Besten die Kopier- und Einfüge Funktion benutzen, um Tippfehler zu vermeiden. Danach bitte die ENTER-Taste drücken oder den OK-Knopf klicken. Ein Informationsfenster wird Ihnen sagen, ob das Passwort akzeptiert wurde.

2.

Falls das JCrystal Fenster nicht innerhalb einger Sekunden erscheint bitte nocheinmal auf die Ikone doppel-klicken. Wenn das Hauptfenster erscheint klicken sie den Dateiöffnungsknopf oder klicken auf das [dir] Abteil.

3.

Die beige Roll-Liste mit bevorzugten Verzeichnissen enthält neben "hkl\" weitere Verzeichnisnahmen wie z.B. "hkl\Dave_Barthelmy" und "hkl\Udo_Behner". Sie können ein beliebiges Verzeichnis mit Beispieldateien wählen.

Dann wählen Sie eine Datei von der Dateiliste zum Laden. Sie können entweder auf den Dateinamen doppel-klicken oder den [open]-Knopf klicken, um die datei zu Laden, wonach die berechnete Kristallform dargestellt wird.

4.

Klicken Sie mit der rechten Maustaste auf das Grafikfenster um in den Benutzerfarbmodus zu gehen und dann wählen Sie das [html] Abteil.

5.

Klicken Sie den [create]-Knopf, um Ihre erste Webseite mit dem JCrystalApplet zu erzeugen. Ihr Standardwebbrowser sollte dann erscheinen und die erzeugte Seite mit dem eingebundenen JCrystalApplet, welches den Kristall zeigt, darstellen.


Datei Editor

Der Editor zeigt mehrere Textfelder für die Eingabe des Titels, der Gitterkonstanten und der Flächenliste (hkl-Indizes). Unten ist der Farbwähler für die Auswahl der Einheitsfarbe (mono color) des Kristalls und der individuellen Einzelfarben der Flächen.

  1. Titel oder Beschreibung
  2. Gitterkonstanten
  3. Flächentabelle mit hkl-Indizes und Zentraldistanzwerten
  4. Wahlkästchen (klicken mit der rechten Maustaste weisst aktuelle Palettenfarbe zu)
    Nach einem an/abhaken können Sie die ENTER-Taste drücken, um alle anderen Flächen der gleichen Farbe an/abzuhaken
    Sie können die DEL-Taste drücken, um alle angehakten Flächen zu entfernen.
  5. Farbauswahl (siehe unten; linke/rechte Maustaste benutzen)
  6. Laden des standard Palettendialogfensters
  7. Eingabedatei öffnen
  8. Neue Datei anfertigen (leert den Editor)
  9. Datei speichern
  10. Kristall berechnen/neu berechnen
  11. Automatische Distanzmodifizierung (reduziert Distanzen von Flächen, welche außerhalb des aktuellen Polyeders liegen)

Flächentabelle

  • 1. Spalte:
    Wahlkästchen; mit der linken Maustaste anhaken. Mit der rechten Maustaste können Sie der Fläche eine andere Farbe zuweisen.
  • 2-4. Spalte:
    h k l (ganzzahlige oder rationale Zahlen)
  • 5. Spalte:
    Zentraldistanz der Fläche, welche manuell geändert werden kann oder mit dem Distanzschieber. Zum letzteren muß das Wahlkästchen der Fläche angehakt sein.

Farbauswahl

linke Maustaste ziehen
ändern der Einheitsfarbe des Kristalls (Darstellungsmodus 1)
rechte Maustaste klicken
ändern der Einheitsfarbe des Kristalls (Darstellungsmodus 1)
linke Maustaste klicken
Farbwahl für die Einzelfarbe der Flächen;
Dann können Sie mit der rechten Maustaste auf ein Wahlkästchen in der hkl Tabelle klicken, um die gewählte Farbe der entsprechenden Fläche zuzuweisen (Einzelfarbe für Darstellungsmodus 2)


Datei Browser

Der Datei Browser hat eine Roll-Liste (beige) für bevorzugte Verzeichnisse, zu welcher andere Verzeichnisse hinzugefügt werden können. Die Trennwände der einzelnen Unterteilungen können hoch/runter gezogen werden, um die Fenstergrößen zu verändern.

  1. Anzeige des aktuellen Verzeichnisses
  2. Aktuelles Verzeichnis zum Roll-Liste hinzufügen
  3. Aktuelles Verzeichnis von Roll-Liste entfernen
  4. Verzeichnis und Dateiliste auffrischen
  5. Roll-Liste (bevorzugte Verzeichnisse)
  6. Verzeichniswähler
  7. Verzeichnisinhalt (Dateiliste; doppel-klicken um Datei zu öffnen)
  8. Textanzeige für die gewählte Datei
  9. Anzahl der Dateien in der Dateiliste
  10. Dateinamen Filter (*.*, *.hkl, *.jcr; *.txt) etc.
  11. Laden der Datei (wenn nicht schon durch doppel-klicken gekladen)

Die hkl einer geladenen Datei werden automatisch in den Editor zur Weiterbearbeitung geladen

.


Form Wähler

Dieses Dialogfenster erzeugt eine Liste von symmetryequivalenten hkl-Indizes für eine eingebene Form und für die gewählte Puntgruppe (Symmetry Klasse)

  1. Punktgruppe auswählen
  2. Eingabe der Indizes einer Form (durch LEERZEICHEN getrennt)
  3. Anfangszentraldistanz
  4. Flächenfarbe für die zu erzeugenden Flächen (Einzelfarbe)
  5. Berechnen der einzelnen Flächen (hkl)
  6. Anzahl der erzeugten hkl
  7. Neue hkl Liste der Form (Zeilen können noch manuell entfernt werden)
  8. Klicken um die neuen hkl zur Flächentabelle des Editors hinzuzufügen
  9. Leeren der hkl Liste in diesem Fenster

Sie können dann entweder andere Formen (mit anderer Einzelfarbe) erzeugen oder gleich zum Editor zurückkehren und den gesamten Kristall zur Darstellung neuberechnen.


Optionen

Optionen Dialog

In diesem Dialogfenster können Sie verschiedene Parameters für die Kristalldarstellung und Hintergriunddarstellung verändern. Probieren Sie einfach alle Elemente aus, um deren Effekt auf die Darstellung zu sehen.


HTML Erzeuger

Dieses Dialogfenster erlaubt die Modifizierung mehrerer Parameter für die Erzeugung von Webseiten und das JCrystalApplet.


Photo Betrachter

Dieses Dialogfenster erlaubt die Zuweisung eines Photos zur erzeugten Kristallform. Mineralienphotos können von mehreren Internetaddressen heruntergeladen werden. Einge Referenzen (Internet Links) sind unter dem Hilfsmenü [Help] angegeben. Es können auch Bilder von Büchern eingescannt werden. Da alle Photos im Internet meist durch ein Copyright geschützt sind, ist nur ein Beispielphoto in der JCrystal Installation enthalten.

Klicken Sie auf den [photo]-Rahmen um ein Bild zum Laden zu wählen.

Im unteren Textfeld können Sie einige Notizen zum Bild oder der erzeugten Kristallform eingeben.


Wulff-Netz Monitor

Dieses Dialogfenster zeigt ein Wulff-Netz mit der stereographischen Projektion der Flächenpole für die aktuelle Kristallform. Diese Darstellung ist automatisch mit den Kristalldrehungen synchronisiert.

  1. Wulff-Netz Monitor
  2. Halbkugelwahl (obere, untere, beide)
  3. Berechnen des Winkels zwischen zwei Flächen


Hauptfenster

Das Hauptfenster besteht aus dem Grafikfenster, den Menüs, dem Editorfenster und der Toolbar. Das Grafikfenster selbst ist das interaktivste Element. Es reagiert auf Mausaktionen oder Tastaturaktionen . Man muss eventuell erst auf das Grafikfenster klicken, um den Tastaturfokus auf dieses zu verlagern.

Toolbar

!!! Einige Knöpfe haben verschiedene Bedeutungen für das Klicken mit der linken Maustaste (L) oder mit der rechten Maustaste (R) !!!

  1. Drehmodus (Maus ziehen für Drehungen)
  2. Zoommodus (Maus ziehen für Zoomen)
  3. Editorfenster ein/aus
  4. Größe automatisch an das Fenster anpassen
  5. L-Linksdrehung, R-Rechtsdrehung
  6. L-Drehung nach oben, R-Drehung nach unten
  7. L-entgegen der Uhrzeigerrichtung, R-in Uhrzeigerrichtung
  8. L-Größer, R-Kleiner
  9. Stereo Paar an/aus
  10. Othonormale/Perspectivische Projektion
  11. L-Flächennormalen an/aus, R-Normalenfarbe wählen
  12. L-hkl Indizes an/aus, R-hkl Farbe wählen
  13. L-Flächennummer an/aus, R-Farbe der Flächennummern
  14. L-Ecknummern an/aus, R-Farbe der Ecknummern
  15. Grafik drucken
  16. Einheitsfarbe / Einzelfarbe / Drahtmodell / Anaglyph

Für Drehungen können auch die Pfeiltasten der Tastatur benutzt werden.


Verzeichnisse

Die Verzeichnisstruktur von JCrystal sieht so aus.

..\JCrystal\hkl\

..\JCrystal\html\

..\JCrystal\lib\

..\JCrystal\pic\

..\JCrystal\ps\

..\JCrystal\vrml\

..\JCrystal\povray\

Eingabedateien für Kristallflächen

gespeicherte html Dateien für das JCrystalApplet

JCrystal Programmdateien (keine Datei ändern!)

gespeicherte GIF und JPG Bilddateien

gespeicherte PostScript Dateien

gespeicherte VRML Dateien

gespeicherte POVray Dateien


Dateiarten

Eingabedateien

  • JCrystal Dateien mit Flächendaten (*.*, *.hkl, *.jcr,*.txt) (Dateiendung ist nicht wichtig)
  • Bilddateien für die Photoanzeige (*.gif, *.jpg)
  • Importieren von Dateien vom Programm FACES 3.5 (*.fac)
  • Importieren von Dateien vom Programm SHAPE 6 "face details files" (*.shd)

    Shape's "details files" *.SHD müssen für Einzelkristalle sein, nicht für Zwillinge!
    FACES 3.5 Dateien enthalten keine geeigneten Distanzwerte für die Flächen! JCrystal versucht, die hkl-Liste von den gegebenen Formen zu erzeugen, aber die Distanzen müssen manuell angepasst werden, um die gleiche Kristallform wie im Programm FACES 3.5 zu erzeugen.

Ausgabedateien

  • JCrystal Dateien mit Flächendaten (*.hkl, *.jcr)
  • Bilddateien (*.gif, *.jpg)
  • Vrml Dateien -Virtual Reality Modeling Language (*.wrl)
  • PostScript Grafikdateien (*.ps)
  • POVray files (*.pov) für Ray Tracing
  • Interaktive Webseiten (*.html)

Eingabedateiformat

JCrystal's Eingabedateien benutzen ein sehr einfaches Textformat. Alle Zahlen müssen durch ein LEERZEICHEN getrennt sein.

Klicken Sie hier für Details


Dateiformat

JCrystal's Eingabeformat

JCrystal's Eingabedateien benutzen ein sehr einfaches Textformat. Alle Zahlenwerte müssen durch ein LEERZEICHEN getrennt sein. Wenn Sie einen anderen Texteditor zum Erzeugen der Dateien benutzen, wie z.B. Notepad, so können Sie auch Formen anstatt aller Einzelflächen angeben, um das Eintippen von Daten zu minimisieren. JCrystal wird jedoch später die hkl-Dateien immer mit der vollen Flächenliste speichern (Einzelflächen).

1.Wenn nur Flächen angegeben sind:

  • 1. Zeile - beliebiger Titel
  • 2. Zeile - Gitterkonstanten
  • 3. Zeile - Anzahl der Flächen
  • ab 4. Zeile - h k l Distanz R G B (RGB sind Farbkomponenten Rot-Grün-Blau)

z.B.:

Dies ist ein Würfel
1 1 1 90 90 90
6
 1  0  0  1.0  255 0 0
 0  1  0  1.0  255 0 0
 0  0  1  1.0  255 0 0
-1  0  0  1.0  255 0 0
 0 -1  0  1.0  255 0 0
 0  0 -1  1.0  255 0 0

2.Wenn Formen angegeben sind:

  • 1. Zeile - beliebiger Titel
  • 2. Zeile - Gitterkonstanten + Punktgruppennummer
  • 3. Zeile - Anzahl der Flächen
  • ab 4. Zeile - h k l Distanz R G B + "form"-Schlüsselwort
Dies ist ein verzerrter cube-octahedron 1
1 1 90 90 90 32
3
 1  0  0  1.0  255 0   0    form
 1  1  1  1.0  0   0   255  form
 1  1  1  0.7  0   255 0

In diesem Beispiel überschreibt die letzte grüne (111)-Fläche die blaue (111)-Fläche, welche von der {111}-Form erzeugt wurde.

Von JCrystal benutzte Punktgruppennummern und Symbole

 #   Symbol
 1   1
 2  -1
 3   2
 4   m
 5   2/m
 6   222
 7   mm2
 8   mmm
 9   3
10  -3
11   32
12   3m
13  -3m
14   4
15  -4
16   422
17   4/m
18   4mm
19  -42m
20   4/mmm
21   6
22  -6
23  -6m2
24   622
25   6/m
26   6mm
27   6/mmm
28   23
29   432
30   m-3
31  -43m
32   m-3m
33   235
34   m-3-5


Menüs

[File] Datei Menü
open hkl-file | Öffnen einer Eingabedatei mit hkl-Liste
new hkl-file | Leert den Editor zum Erzeugen einer neuen hkl-Datei
reload | Wiederladen der aktuellen hkl-Datei
save as PS | Speichern einer PostScript Datei. Sie sollten die Public Domain Software GHOSTSCRIPT+GHOSTVIEW zum Betrachten und Drucken dieser Dateien benutzen. Sie können dann auf jedem installierten Drucker drucken. Ein spezieller PostScript-Drucker ist nicht nötig!
save as HTML | Speichern einer HTML Datei mit der aktuellen Kristallform zur Darstellung mit dem JCrystalApplet in einer Webseite. Sie können den erzeugten Code auch manuell in andere Webseiten kopieren.
save as JPG | Speichert die aktuelle Grafik als JPG Datei (mehr als 65000 Farben möglich).
save as GIF | Speichert die aktuelle Grafik als GIF Datei (maximal 256 Farben möglich).
save as VRML | Speichern der Form als VRML Datei (Virtual Reality Modeling Language) zur Betrachtung in einem Webbrowser oder mit einem externen VRML Betrachter wie GLview3.6 .
add to VRML | Dies ist ein einfacher Weg zum Erzeugen durchwachsener Kristalle. Wenn Sie eine VRML Datei gespeichert haben, können Sie den Kristall drehen und dann diese Funktion benutzen, um den gedrehten Kristall hinzuzufügen. Ein VRML Betrachter zeigt dann beide (oder mehrere) Kristalle als eine Durchwachsungsform an.
save as POVRAY | Speichern der Form als POVRAY Datei (*.pov) zur Benutzung mit dem kostenlosen Ray Tracer POVray
print | Drucken der aktuellen Grafik. Sie könnten das Bild auch erstmal als GIF/JPG Datei speichern und dann ein anderes Grafikprogramm zum Betrachten und Drucken benutzen.
Exit | Schließen des Programmes JCrystal
[View] Menü
editor | Editor Fenster an/aus (für größeres Grafikfenster)
distance slider | Distanzschieber an/aus (zur Änderung der Zentraldistanzen für angehakte Flächen)
editor swap side | Wechsel des Editors zur Linken/Rechten Seite
view VRML file | VRML Betrachter zum Anzeigen der zuletzt gespeicherten VRML Datei
GUI appearance .. | Wechsel zwischen WINDOWS und JAVA Interface
1. unit cell viewer | Elementarzellenbetrachter
2. stereographic projection | Wulff-Netz Modul
3. Laue patterns | Laue Simulationsmodul
4. periodic table | Periodensystem der Elemente
5. paper models | Auswahl von Papiermodellen
[Edit] Editieren Menü
form explorer | Erweiterte Version des Formwählers, der auch Mauseingabe erlaubt
unselect all faces | Alle Flächen im Editor abhaken
remove selected faces | Alle angehakten Flächen vom Editor entfernen
reset distance slider | Distanzschieber wieder auf Null setzen. Die Distanzen von angehakten Flächen werden wieder zurückgesetzt. Wenn Sie diese nicht zurücksetzen wollen, haken Sie die Flächen vorher ab.
advanced .. | Toleranzwerte zur Kristallformberchnung ändern. Diese Werte werden auch an das JCrystalApplet weitergeleitet, so daß es die gleichen Kriterien zum Berechnen der Kristallform nutzen kann
automatic distance | Automatische Distanzwerte falls einige Flächen nicht sichtbar sind, da ihre Distanzen zu groß sind. JCrystal wird ihre Distanzen verkleinern bis die Flächen sichtbar werden. Die Werte können dann manuell oder mit dem Schieber weiter verändert werden
[Display] Darstellungs Menü
fit to screen | Kristallgröße an das Grafikfenster anpassen
shaded | Kristall mit Einheitsfarbe. Die Farbe kann durch ziehen der linken Maustaste über den Farbwähler des Editors geändert werden
custom color | Kristall mit Einzelfarben (durch Benutzer im Editor festgelegt)
wire frame | Drahtmodell
anaglyph | Rot-Blau Stereo (rot/blaue Brille notwendig für 3D-Effekt)
vertices | Nur Ecken als Punkte zeichnen
line drawing 1 | Transparente schwarz/weiß Zeichnung
line drawing 2 | Nichttransparente schwarz/weiß Zeichnung
show indices | Miller Indizes (hkl) an/aus (auch mit "i"-Taste)
show face numbers | Flächennummer an/aus (auch mit "n"-Taste)
show vertex numbers | Eckennummer an/aus (auch mit "v"-Taste)
show edges | Kanten an/aus (nur für schattierte Darstellungen)
show normals | Flächennormalen an/aus
stereo pair | Stereo Paar an/aus (auch mit "s"-Taste)
[Rotation] Drehungs-Menü
around X: 90 deg | 90 Grad Drehung um die Bildschirmnormale
around X: -90 deg | -90 Grad Drehung um die Bildschirmnormale
around X: custom | Eingabe des Drehwinkels um die Bildschirmnormale
around X: auto | Start Animation um die Bildschirmnormale
around Y: 90 deg | 90 Grad Drehung um die horizontale Achse
around Y: -90 deg | -90 Grad Drehung um die horizontale Achse
around Y: custom | Eingabe des Drehwinkels um die horizontale Achse
around Y: auto | Start Animation um die horizontale Achse
around Z: 90 deg | 90 Grad Drehung um die vertikale Achse
around Z: -90 deg | -90 Grad Drehung um die vertikale Achse
around Z: custom | Eingabe des Drehwinkels um die vertikale Achse
around Z: auto | Start Animation um die vertikale Achse
stop auto rotation | Stoppen der Animation
[Options] Menü
create templates | Erzeugen von über 4000 Schablonen Dateien (Templates von Dave Barthelmy, www.webmineral.com)
print periodic table | Drucken eines farbigen Periodensystems
[History] Menü
cancel | Menü wieder schließen
..... | Vorher geladene Dateien (Verzeichnisname wird als Tooltip angezeigt)
clear history | Alle Einträge entfernen
[Help] Hilfe Menü
about | Programm Information
show key bindings | Liste mit Tastaturabkürzungen
help on JCrystal | Diese Hilfsdatei
JCrystal homepage | (Internetverbindung notwendig) http://www.jcrystal.com
submit bug report | (Internetverbindung notwendig) Webseite zur Mitteilung von Fehlern/Problemen
check for updates | (Internetverbindung notwendig) Webseite mit Update-Informationen
web databases | (Internetverbindung notwendig) Zugang zu Dave Barthelmy's Webmineral Datenbank und der russischen MINCRYST Datenbank
Internet links .. | (Internetverbindung notwendig) Internet Referenzen von mineralogischen Interesse


Tastaturnutzung

Beachten Sie, dass man eventuell erst auf das Grafikfenster klicken muss, um den Tastaturfokus zu verlagern.

Darstellungsoptionen
f
Anpassen and das Grafikfenster
s
Stereo Paar an/aus
i
Indizes an/aus
n
Flächennummern an/aus
v
 Eckennummern an/aus
e
Kantenzeichnen an/aus

The cursor keys may be used for rotations, which might be useful for MAC users.

Kistalldrehungen
SHIFT + Pfeiltaste
Drehung um die x-Achse (Bildschirmnormale)
hoch/runter Pfeiltaste
Drehung um die y-Achse (horizontale Achse)
links/rechts Pfeiltaste
Drehung um die z-Achse (vertikale Achse)
Animationsstart
x X
Animation um die x-Achse (pos./neg. Richtung)
y Y
Animation um die y-Achse (pos./neg. Richtung)
z Z
Animation um die z-Achse (pos./neg. Richtung)
Während einer Animation
Leerzeichen
start/stop der Animation
+
schneller
-
langsamer


Mausnutzung

Ein Doppel-Klick auf das Grafikfenster schaltet die Animation an/aus.

Benutzen Sie bitte die rechte Maustaste und ziehen sie hoch/runter auf der linken und rechten Seite des Grafikfensters, um zu sehen, wie dies einmal zum Drehen und zum Zoomen dient.

Ändern des Darstellungmodus
rechte Maustaste klicken auf dem Grafikfenster
Drehung [ im Dreh-modus ]
linke Maustaste ziehen
Drehung um die y-,z-Achsen (horizontale/vertikale Achse)
rechte Maustaste ziehen
Drehung um die x-Achse (Bildschirmnormale)
Zoomen [ im ZOOM-Modus ]
linke Maustaste ziehen
Ein-/Auszoomen der Grafik
Farbpalette des Editor's

linke Maustaste ziehen
Ändern der Monofarbe des Kristalls
linke Maustaste klicken
Wählen der Flächenfarbe; dann können Sie mit der rechten Maustaste auf das Kästchen einer Fläche klicken, um der Fläche die gewählte Farbe zuzuweisen.


POVray

POVray - Persistence of Vision™ Ray Tracer

JCrystal kann Kristallformen als POVRAY Dateien (*.pov) erzeugen.
POVray ist kostenloses Programm, welches bei http://www.povray.org heruntergeladen werden kann.

Exportieren von Kristallformen für das Raytracing

Wählen Sie den Menüeintrag [File][save as POVRAY], wonach Sie nach einen Dateinamen gefragt werden. Dann erscheint das folgende Dialogfenster mit Darstellungsoptionen.

JCrystal versucht, automatisch das Installationsverzeichnis von POVRAY zu finden, so dass es auch von JCrystal aus gestartet werden kann. Falls JCrystal es nicht gefunden hat, klicken Sie den [path]-Knopf und lokalisieren die Datei [povray_install_directory]\bin\pvengine.exe .


Anleitung

  • Wie erzeuge ich eine Quasikristallform ?
  • Wie erzeuge ich eine normale Kristallform ?
  • Wie benutzt man die Form Explorer ?
  • Wie ändere ich die Zentraldistanzen ?


Impressum

Kontakte

Autor:

Steffen Weber
Livermore, CA 94550, USA

Tel.:

Email:
Web:

 +1(USA) 925-455-1669

jcrystalsoft@gmail.com
http://www.jcrystal.com

JCrystalSoft Webseite:

http://www.jcrystal.com


Einheitszelle-Betrachter

Elementarzellenbetrachter (Unitcell Viewer)

Dieses Modul ist zum Visualisieren von räumlichen Beziehungen zwischen den Gittervektoren [uvw] und den Flächennormalen (hkl). In den meisten Fällen wird der (hkl) Vektor zu kurz sein. Haken Sie das Kästchen [unit length] an und benutzen Sie den Schieber (#9), um die Vektorlängen anzupassen. Nur die Vektoren deren Kästchen angehakt ist werden gezeichnet.

Lassen Sie ein LEERZEICHEN zwischen den Vektorkomponenten h k l oder u v w wenn Sie Vektoren eingeben.

  1. Grafikfenster - mit der Maus drehen
  2. Farbeinstellungen
  3. Gitterkonstanten
  4. Vektorlängen und Winkel
  5. Wechsel Drehmodus mit Zoommodus (linke Maustaste) & Verschieben (rechte Maustaste)
  6. Stereo Paar an/aus (Parallelprojektion)
  7. Orthonormale/perspektivische Projection an/aus
  8. Skaliere Vektoren aud Einheitslänge
  9. additional scaling factor if unit length is selected
  10. Änderungen anwenden und neu berechnen
  11. Vektorindizes und Auswahlkästchen


Stereogramme

Ein Modul zum Zeichnen von stereographischen Projektionen der Vektorpole (hkl) oder Zonenachsen [uvw] auf einem Wulff-Netz. Das Wulff-Netz kann durch ziehen mit der rechten Maustaste verschoben werden.

  1. Menüs
  2. Farbeinstellungen
  3. Wahl des Orientierungsvektortyps
  4. Orientierungsvektorindizes (getrennt durch LEERZEICHEN)
  5. Maximum Index für hkl-Schleife (intern wird der doppelte Wert benutzt, um alle Equivalente zu finden!)
  6. Gitterkonstanten
  7. Wahl des d-Wert range as additional criterion
  8. Drehwinkel
  9. Schieber für Zoom und Drehungen (Wälzen)
  10. Änderungen anwenden
  11. Grafikfenster (klick einen Pol für die Anzeige der Indizes; rechte Maustaste ziehen zum Verschieben)


Laue Simulationen

Dieses Modul berechnet geometrische Laue Diagramme (keine Intensitätsberechnung, da keine Struktur gegeben ist)

  1. unit cell constants
  2. Laue geometry - transmission/back reflection
  3. color settings
  4. annotation for printout
  5. orientation vector (h SPACE k SPACE l)
  6. maximum index for hkl-loop (used if [Option][Automatic hkl limits] unchecked)
  7. X-ray generator voltage for minimum wavelength
  8. film width/height
  9. film distance
  10. lattice type for Bravais extinctions
  11. spot radius option
  12. swap x-coordinates (look towards beam or away from it)
  13. Apply changes (recalculate)
  14. zoom slider (also right-mouse-drag in right half of main display)
  15. threshold for displaying hkl labels


Periodensystem

Periodensystem der Elemente

  1. Periodensystem (klicken Sie einen Kasten zur Elementwahl)
  2. Zahlenwert der gewählten Eigenschaft
  3. Graph der Eigenschaftswerte für alle Elemente (Ordnungszahl 1-98) (Graph klicken zur Elementwahl)
  4. Wählen Sie eine Elementseigenschaft für die Graphdarstellung


Papiermodelle

JCrystal bietet eine kleine Anzahl von Polyedern als faltbare Papiermodelle an, welche nach Bedarf ausgedruckt werden können. Diese Auswahl könnte in Zukunft eventuell erweitert werden.

Klicken Sie die Farbknöpfe um die Polygonfarben zu ändern.


New Page 1

Wie erzeuge ich eine normale Kristallform ?

Erst das Menü [File][New hkl-file] wählen, um eine neue Kristallform zu beginnen.

Um eine neue Kristallform zu erzeugen kann man entweder die hkl-Indizes aller Flächen eintippen oder einen Formwähler benutzen (Form Explorer), um die symmetrieäquivalenten {hkl} von den Eingabeindizes einer Fläche zu erzeugen. Dazu geht man auf das "form"-Abteil und wählt die gewünschte Punktgruppensymmetie aus. Dann gibt man die hkl-Indizes der Startfläche (h LEERZEICHEN k LEERZEICHEN l) und die Distanz ein, wählt die Farbe für die zu erzeugenden Flächen und klickt den Knopf [get hkl list] und danach den Knopf [add to list], wodurch die erzeugte Liste im Editor angehängt wird. Diese Schritte wiederholt man für alle Formen, die man hinzufügen möchte.

Das folgende Beispiel zeigt die Erzeugung der {110}- und {111}-Formen mir verschiedener Farbe.

Nachdem die neuen hkl zum Editor hinzugefügt wurden klicken Sie den Knopf [recalculate] (Rechtspfeil), um die neu erzeugte Kristallform darzustellen.

Flächen, die nicht sichtbar werden, da ihre Distanzen zu gross sind zeigen ein rotes "dist"-Feld im Editor. Man muss dann deren Distanzen verändern, um sie sichtbar zu machen. Man kann entweder neue Werte eintippen und dann den Knopf [recalculate] klicken oder den Automatikknopf (Auto-adjust) klicken, wonach JCrystal versucht, alle Distanzen automatisch so weit zu ändern, bis die fehlenden Flächen sichtbar werden.

Falls man die Benutzung des Distanzschiebers vorzieht siehe "Wie ändere ich die Zentraldistanzen ?"

Vergessen Sie nicht, Ihre neu erzeugte Kristallform unter einem sinnvollen Dateinamen zu speichern.


New Page 1

Wie ändere ich die Zentraldistanzen ?

Ein einfach zu verwendendes Hilfsmittel zur Veränderung der Zentraldistanzen gewählter (angehakter) Flächen ist der Distanzschieber. Er wird durch den Menüeintrag [View][Distance slider] an/ausgeschalten.

Klicken Sie an die Kästchen im Editor, um diejenigen Flächen zu wählen, deren Distanz geändert werden soll. Danach bewegen Sie den Schieber bis Sie die gewünschte Kristallform erhalten haben.

Die Schieberaktion kann durch den Menüeintrag [Edit][Reset distance slider] rückgängig gemacht werden.

Im folgenden Beispiel wurde die (100)-Fläche ausgewählt und seine Distanz verändert.


New Page 1

Wie benutzt man die Form Explorer ?

In JCrystal gibt es zwei Form Explorer (Formwähler), welche von den Indizes (hkl) einer Fläche alle symmetrieäquivalenten {hkl} erzeugen können.

Wenn die Indizes hkl der Eingabefläche bekannt sind, sollte man den Form Explorer im "form"-Abteil benutzen. Erst die Punktgruppe auswählen, dann die Flächenindizes hkl (Format: h LEERZEICHEN k LEERZEICHEN l) und Anfangsdistanz eingeben. Dann die Farbe für die zu erzeugenden Flächen wählen und den Knopf [get hkl list] klicken. Die erzeugten hkl Indizes werden im Textfenster aufgelistet, wo Sie noch einzelne Zeilen manuell entfernen können. Klicken Sie den Knopf [add to list], um die erzeugte Liste zu akzeptieren und zum Editor zu senden. Nachdem die neuen Flächenindizes zur Flächenliste des Editors hinzugefügt wurden, können Sie den Berechnungsknopf (Rechtspfeil) klicken, um die neue Kristallform zu erzeugen. Eventuell müssen die Zentraldistanzen einzelner Flächen noch angepasst werden, um all Flächen sichtbar zu machen.

Wenn man den Form Explorer vom Menü [Edit][Form explorer] benutzt, kann man auch die Maus zur Eingabe benutzen indem man für die gewählte Punktgruppe auf das Wulff-Netz klickt und den Pol mit gedrückter Maustaste herumzieht. Wenn man die Maustaste loslässt, wird eine Vorschau der erzeugten Form angezeigt, welche auch mit der Maus gedreht werden kann.

Bild.: Form Explorer und einfacher Formerzeuger


New Page 1

Wie erzeuge ich eine Quasikristallform ?

Um die Form eines ikosaedrischen Quasikristalles zu erzeugen kann man den Formwähler vom Menü [Edit][Form explorer] benutzen.
Zuerst wählt man das Menü [File][New hkl-file], um den Editor zu leeren und eine neue Form zu beginnen. Dann öffnet man den Formwähler und folgt die Schritte:

Bild: Schritte zur Erzeugung einer Quasikristallform

Zur Erzeugung ikosaedrischer Quasikristallflächen kann man entweder sechs ganzzahlige Indizes (hklmno) oder drei rationale Indizes benutzen. Die letztgenannte Methode wird in JCrystal benutzt.